Перейти к содержанию

Дополнительные возможности

Открытие базы данных

Чтобы открыть ранее созданную базу данных, в меню "Файл" выберите пункт "Открыть базу данных", или на панели инструментов нажмите кнопку image, или нажмите комбинацию клавиш Ctrl+O.

В открывшемся окне выберите нужную базу данных:

image alt center

База данных будет открыта, программа покажет соответствующее сообщение:

image alt center

Примечание

Программа запоминает файл, с которым она работает.

Каждый раз открывать базу не нужно! Открытие выполняется только после установки программы на другой компьютер, либо для последующей работы с другой базой данных.

Сохранение базы данных

Чтобы сохранить базу данных данных под другим именем и/или в другом каталоге, в меню "Файл" выберите пункт "Сохранить базу данных как..." или на панели инструментов нажмите кнопку image.

В открывшемся окне укажите новое имя файла, которое отличается от предыдущего, и/или выберите каталог для сохранения.

image alt center

Нажмите кнопку "Сохранить".

После этого программа начнет работать с новым файлом, являющимся полной копией старого. Старый файл также хранится на диске.

Примечание

Во время работы с программой данные сохраняются автоматически и нет необходимости в периодическом сохранении информации.

Сжатие и восстановление базы данных

Для эффективной и быстрой работы программы необходимо постоянно следить за файлом базы данных. Эта особенность продиктована форматом файла Microsoft Access. Формируемые запросы к базе данных, массовое добавление или удаление записей увеличивают объем файла, из-за чего программа постепенно начинает работать медленнее, а, кроме того, могут случиться серьезные сбои в работе и потеря информации (причем сразу всей, т.к. вся информация хранится в одном файле).

Каждый день при первом запуске программы автоматически проводится восстановление и сжатие базы данных. Чтобы эта операция была наиболее безопасной, сначала формируется копия файла базы данных, имя файла которой *_backup.mdb, далее эта копия сжимается в файл *_compact.mdb и перезаписывается на место исходного файла.

Примечание

Копии базы данных хранятся в каталоге .../Диплом-стандарт ФГОС СПО/CompactBD.

Сжатие и восстановление базы данных позволяет уменьшить размер базы данных, а значит, повысить скорость работы программы и устойчивость против сбоев.

Чтобы вручную выполнить сжатие и восстановление, в меню "Сервис" выберите пункт "Сжать базу данных".

Примечание

Для выполнения сжатия и восстановления программа должна быть запущена в монопольном режиме.

После выполнения процесса программа выдаст соответствующее сообщение:

image alt center

Архивирование базы данных

Чтобы создать резервную копию текущей базы данных, в меню "Сервис" выберите пункт "Архивировать базу данных".

При выполнении архивации производится сжатие и восстановление текущего файла базы данных, а затем его архивирование в каталог Архив в каталоге, где установлена программа.

Примечание

Для выполнения сжатия и восстановления программа должна быть запущена в монопольном режиме.

Для более надежной защиты, рекомендуется выполнять копирование резервной копии файла базы данных на другой жесткий диск или флеш-накопитель.

Копирование базы данных на съемный носитель

Для резервного копирования данных, а также для сотрудников, которые работают с программой на разных компьютерах, например, на работе и дома, есть удобная возможность копировать базу данных на съемный диск, то есть флеш-накопитель, а, перейдя на другой компьютер, восстанавливать информацию с флеш-накопителя и продолжать работу.

Чтобы скопировать базу данных:

  • подключите накопитель к компьютеру;
  • в меню "Файл" выберите пункт "Скопировать на съемный диск";
  • в открывшемся окне подтвердите копирование:

    image alt center

Примечание

Если к Вашему компьютеру подключено несколько съемных дисков, то будет выдано окно для выбора нужного диска:

image alt center

Выберите диск и нажмите "OК".

База данных будет скопирована в корневой каталог флеш-накопителя:

image alt center

Вместе с файлом базы данных, на флешь записывается файл ds.txt, внутри которого указывается имя файла базы данных. Файл необходим для восстановление базы данных.

Примечание

Если на флеш-накопителе уже был записан файл с таким именем – он будет заменен (без предупреждения).

Восстановление базы данных со съемного носителя

Если база данных была предварительно записана на съемный диск, то можно автоматически восстановить информацию путем копирования со съемного диска на жесткий диск.

Чтобы восстановить базу данных:

  • подключите накопитель к компьютеру;
  • в меню "Файл" выберите пункт "Восстановить со съемного диска";
  • в открывшемся окне подтвердите восстановление:

    image alt center

Примечание

Если к Вашему компьютеру подключено несколько съемных дисков, то будет выдано окно для выбора нужного диска:

image alt center

Выберите диск и нажмите "OК".

База данных будет скопирована в каталог с программой, затем автоматически открыта:

image alt center

Примечание

Если на жестком диске уже имеется файл с тем же именем, что и восстанавливаемый, то этот файл будет переименован в файл "Имя (1).mdb".

Примечание

Если база данных была скопирована на флеш-накопитель не с помощью функции "Скопировать на съемный диск", а вручную, либо на съемном диске был удален файл *.txt, то будет выдано окно диалога для выбора файла базы данных.

image alt center

Выберите файл и нажмите кнопку "Открыть".

Переход на новую базу данных

Для того чтобы убрать в архив данные выпускников прошлого года в программе предусмотрена возможность перехода на новую базу данных.

Для перехода на новую базу данных, в меню "Сервис" выберите пункт "Переход на новую базу данных".

Примечание

Для выполнения перехода программа должна быть запущена в монопольном режиме.

Подтвердите переход - нажмите "Да".

image alt center

Примечание

Чтобы отменить переход, нажмите "Нет".

Будет создана копия базы данных - база сохранится с именем *_(0).mdb (при дальнейшем переходе файла будет *_(1).mdb) в корневую папку программы.

image alt center

В текущей базе данных будут очищены справочники "Студенты", "Итоговые оценки". В справочнике "Учебные группы" все даты увеличатся на 1 год.

image alt center

Вверх